Introduccion a la simulacion con ModelSim.

Este es un resumen de la funcionalidad basica del simulador ModelSim.

Model Sim permite muchas cosas mas. Puede encontrar mas informacién en Help->PDF
Documentation->Tutorial y Help->PDF Documentation-> User’s manual. Tenga en cuenta
que no todas las caracteristicas de ModelSim estan permitidas en una licencia de
estudiante.

Crear un proyecto.

Seleccione en la barra de mendus File->New->Project. Defina nombre de proyecto y path
donde va a residir. Deje el resto de opciones en valores por defecto.

Seleccione Add Existing File y agregue los ficheros VHDL.
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Se pueden agregar o eliminar ficheros del proyecto picando con el botén derecho del ratén
en la pestafia Project de la ventana Workspace. También se pueden agregar ficheros en la
entrada de menu Project.

Cuando se cierre el ModelSim, se guarda automaticamente el proyecto. Puede invocar el
proyecto la siguiente vez seleccionando File->Open y seleccionando los tipos de fichero
proyecto.

Compilacion del proyecto.
Compile->Compile All
Los ficheros que componen el proyecto se encuentra en la pestafia Project de la ventana

Workspace.

En caso de que haya un error, aparecera una indicacién en la ventana Transcript.



Hacer doble click sobre el mensaje de error o seleccionar Compile->Compile Summary hara
que se abra una ventana con el listado de los errores. Abrir el fichero y editarlo picando en
el fichero correspondiente en la lista que aparece en la pestafia Project, ventana
Workspace.

Recompile hasta que no tenga mas errores de sintaxis.
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# Loading project P1 -- Loading package std_logic_arith
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Simulacion del diseiio.

Seleccionar Simulate->Start Simulation
Se abrirad un didlogo donde se seleccionara el diseiio a simular, dentro de la libreria work. El
diseno a simular sera el “testbench”.
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Se abrirdn nuevas pestafias y ventanas dentro del area de trabajo. Ver mas abajo:
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La pestafia sim en la ventana Workspace tiene una jerarquia de los objetos VHDL (packages,
componentes, procesos,... Jdel disefo. Si se pica dos veces con el botén izquierdo del ratén
sobre el objeto, se abrira el fichero que contenga ese objeto posicionado en su declaracién.

En la figura anterior, en la pestafia sim, ventana Workspace, las lineas clk_process y
stim_proc debajo de ple3 tb2 corresponden a los procesos que con esas etiquetas se
encuentran en ple3 tb.vhd. A su vez, uut corresponde a la instanciacion del componente
dec3_8_reg. Es posible abrir esa linea, dando acceso a los procesos que hay en ese
componente (fichero ple3.vhd); como en este caso no tienen etiqueta, se identifican con el
numero de linea.

Agregando senales para la simulacion.

Si se selecciona ple3 tb2, en la ventana Objects aparecen todas las sefiales que hay en ese
bloque. Se pueden agregar esas sefiales a la ventana wave (que es donde se van a ver los
resultados de la simulacidn) seleccionando las sefiales en la ventana Objects y con el botdn
derecho del ratén seleccionando a Add ->To wave-> Selected Items (o también All items in
region). Esta operacién también se puede hacer de forma similar seleccionando el objeto
en la pestafia sim, ventana Workspace.
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NOTE que si selecciona uut en la ventana sim, las sefiales que aparecen en la ventana
Objects no son las mismas, sino las pertenecientes a este otro bloque. Asi, pueden aparecer
sefiales internas al bloque dec3_8 reg: en este caso aparece la sefial Q_temp. De esta
manera se pueden ver sefales que estan dentro de otros bloques que no sea el testbench.
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En principio, las sefales tienen que estar agregadas en la ventana wave antes de iniciar la
simulacidn. Si queremos que el simulador registre sefiales adicionales del disefio aunque
por ahora no las muestre podemos afadir sefiales al Log. Por ejemplo, para que se
registren todas las sefales del disefio y que en cualquier momento podamos afiadir mas a
la ventana de ondas sin tener que re-simular podemos ponernos sobre el testbench en la
pestafia sim del Workspace y con el botén derecho del ratén seleccionar Add->To Log->All
items in design.



/] ModelSim SE PLUS 6.4b
File Edit View Compile Simulste Add Structure Teols Layout Window Help

D=8 & ;‘%Qé&’”:;"z';timﬁﬂaﬂﬁﬁﬁ o @ w» %eBe D0t W& a>ﬁ“i«*i.‘zﬁ e EHHEBR TR WO
Hewim‘ J@.ﬁ]ﬁi?}“tavwllislmlace ;|
B el H ,HKEJ B e 0}%’%‘@\/@@J|—ﬂ§ - Jicemzms;” @quw\ %g‘

Workspace =—=——— i

[#instance

Ha#i x| | Objects | [ gl wave - default

8 std_logc_unsigned
Bl £t logic_arith

Bl std_logic_1164
B standard 10000000
& pies th? | = .

T it View Declaral 1

L@ stmpr V= ztor |
[ R —

:DD:DD:)ZPD:D:D:)MJ

Copy

Alltems in region
Find... 2

Al i ekt o §

Expand Selected
Colapse Selected
Expand Al
Collapse All

4; Tt el T

A x

fe- I«

*®
B

v

Bl

i ] e [
Glom | =irid | XM ImportHint IL [ Hipiesvhd | H]pie3 eivhd | H] plez.vhd | H]pies bhd | R datafiow | ples.do | g wave
SERaa i JE R

Transcript End Simulation
VM 31
VM 31>

] Transcript
[Project : pte3 [Now: 200ms Delta: 2 [sim:fo1e3._th2 - Limited Visibiity Region

Si tenemos visualizadas bastantes sefales puede ser util dividirlas por grupos, insertando
divisores con nombre, mediante el comando de menu Add ->Divider o directamente con el
botdn derecho en la zona de sefiales, Insert Divider. Las seiales pueden también
organizarse desplazdndolas abajo o arriba mediante el ratén.

Controlando la simulacion.

Una vez que estan agregadas las sefiales a la ventana Wave, se puede definir representarlas
en hexadecimal seleccionando las sefiales y con el botdn derecho del ratén, Radix->
Hexadecimal. De la misma manera se pueden seleccionar otros formatos como decimal sin
signo (Unsigned), etc. Los nombres de las sefiales adoptan un formato similar a los nombres
de los ficheros en un directorio: /ple3_tb2/uut/q identifica la sefial q dentro del bloque
uut, dentro del bloque ple3 tb2.
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Para simular, pique en los botones Run o Run —all. El primero avanza la simulacién el
periodo de tiempo del formulario adyacente (ej.: 100 ns). El segundo avanza la simulacién
hasta que ésta termine en el testbench (si no hay un comando de parada de simulacién,
esta seguird indefinidamente; en este caso se puede parar la simulacién con la opcién Break
del menu Simulate o el botdn equivalente).
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Cuando un assert falla, aparecera una flecha en la fila de Messages de la ventana de wave.
Pasando el ratdn sobre la flecha, sale el mensaje correspondiente del assert fallido, que
también saldra en la ventana de Transcript. La ventana de Transcript es la encargada de
presentar todos los mensajes de texto que se generan en la simulacion.

Para hacer zoom en una zona de la simulacidn, aparte de los botones con un dibujo de una
lupa, es util utilizar la tecla Ctrl a la vez que se hace un “drag” con el botén izquierdo del
raton. De esta forma, segun la direccidn a la que nos movamos se hara zoom hacia fuera
(out), dentro (in) o vista completa (fit), siendo particularmente util para hacer zoomin en la
zona que demarquemos con eI raton.
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Para reiniciar la simulacién (por ejemplo para agregar mas sefiales si no se registraron)
pulse en el botdn reiniciar, y mantenga todas las ondas que anteriormente habia agregado.

Salvar el formato de las ondas

Es posible salvar el formato que damos a nuestra visualizacidon de ondas en un fichero,
guardando la informacidn sobre sefiales mostradas, “radix” utilizadas y otras caracteristicas
del visor de ondas como uso de colores, separadores, etc. Para hacer esto basta con darle al
botdn de salvar en disco estando la ventana de ondas activa. Por defecto esto creard un
fichero “wave.do”, que es un fichero de script de ModelSim con los comandos necesarios
para configurar la ventana de ondas, y que podra ser cargado en este ventana con el
comando de menu Load.

Comandos y scripts

La ventana Transcript, aparte de visualizar los mensajes del simulador, se comporta como
una consola de comandos. Ademas de ejecutar los comandos propios de ModelSim,
entiende muchos comandos habituales de Linux. Por ejemplo, podemos cambiarnos de
directorio con cd, listar el contenido del directorio con Is, etc. Es también interesante
conocer que con las teclas de flecha arriba y flecha abajo podemos movernos por los
comandos ejecutados anteriormente, de forma que por ejemplo repetir la Gltima
simulacidn puede ser tan sencillo como pulsar la techa flecha arriba y luego la tecla Enter.

Una caracteristica util de ModelSim es que permite utilizar ficheros de script para lanzar sus
comandos, ficheros que normalmente se nombran con la extensién “.do” (por ejemplo la
herramienta ISE de Xilinx genera varios de estos, con diferentes extensiones “.*do”, es la
manera que tiene ISE de decirle a ModelSim qué hacer). Esto nos puede ser util para lanzar
rapidamente la compilacién y simulacién de un disefio incluso sin necesidad de tener un
proyecto creado a tal efecto. A continuacion se muestra un ejemplo de este tipo de scripts,
que entre otras cosas hace uso del script de configuracién de la ventana de ondas wave.do
antes comentado. En el script se usa también el comando “log —r /*” para que el simulador
grabe todas las sefiales y se puedan afiadir nuevas sefiales a la ventana de ondas sin tener
que volver a simular.

Para ejecutar un script basta hacer en la ventana Transcript:
do <nombre_fichero_script>.



# Simulation script
#

# Create library
vlib work

# Compile files
vcom -explicit -93 "ple3.vhd"
vcom -explicit -93 "ple3_tb.vhd"

# Run simulation. Resolution 1 ps, avoid nodes disappearing due to optimization.
vsim -t 1ps -novopt -lib work ple3_tb2

# Record information about all signals
log -r /*

# Load waveforms
do wave.do

# Open windows
view wave

view structure
view signals

# Run full simulation
run —all

Ple3_tb2.vhd

USE ieee.std logic arith.ALL;

ENTITY ple3 tb2 IS
END ple3 tb2;

ARCHITECTURE behavior OF ple3 tb2 IS

-- Component Declaration for the Unit Under Test (UUT)
COMPONENT dec3 8 reg
PORT (
D : IN std logic vector (2 downto 0);
CE : IN std logic;
CLK : IN std logic;
Reset : IN std_logic;
Q : OUT std logic vector (7 downto 0)
)i
END COMPONENT;

--Inputs
signal D : std logic_vector (2 downto 0) (others => '0");
signal CE : std logic := '0';
signal CLK : std logic := '0';
signal Reset : std logic := '0';
—--Outputs

signal Q : std logic vector (7 downto 0);

constant CLK period : time := 10 ns;
constant espera : time := 1 ns;
constant Ninput: integer := 3;

BEGIN



-- Instantiate the Unit Under Test (UUT)
uut: dec3 8 reg PORT MAP (
D => D,
CE => CE,
CLK => CLK,
Reset => Reset,
Q =>Q
) i

CLK _process :process

begin
CLK <= '0";
wait for CLK period/2;
CLK <= '1";

wait for CLK period/2;
end process;

-- Stimulus process
stim _proc: process
begin
--Inicializacion de todo
D <= "000";
CE <= '0";
Reset <= '1";
wait for espera;

-- Chip enable

Reset <= '0';

CE <= "1";

for i in 0 to 7 loop
D <= conv_std logic vector (i,Ninput);
wait until CLK = '1';
wait for espera;

end loop;

- Mas estimulos aqui ..

wait;
end process;

END;

Ple3.vhd

library IEEE;

use IEEE.STD LOGIC_1164.ALL;

use IEEE.STD LOGIC_ARITH.ALL;
use IEEE.STD_LOGIC_UNSIGNED.ALL;

entity dec3 8 reg is
Port ( D : in STD LOGIC_VECTOR (2 downto 0);
CE : IN std logic;
CLK : IN std logic;
Reset : IN std logic;
Q : out STD LOGIC VECTOR (7 downto 0));
end dec3_8 reg;

architecture Practica of dec3_8 reg is
signal Q temp: std logic_vector (7 downto 0);
begin
process (D)
begin
case D is
--Otros casos a incluir
WHEN OTHERS => Q temp <= "10000000";
end case;
end process;

process (Reset, CLK)
begin
-- Codigo registro (a incluir)

end process;

end Practica;



